0

I recently (finally) figured out how to get a monokai theme onto my emacs in the default Terminal app, but emacs still isn't filling up the entire window.

There's a small, but noticeable color discrepancy on the corners.

How do I make Emacs fill up the whole Terminal screen?

Note: This occurs in both windowed and "fullscreen" mode. My resolution is 1440 x 900 (Macbook Air 2015 resolution). However, I do use multiple monitors frequently, so a general solution would be very much preferred. Thank you!

enter image description here

11
  • Are you sure that's not the fringe?
    – Dan
    Sep 16, 2015 at 23:27
  • I'm sorry, can you define what the fringe is? It's using the same theme as my default terminal (different kind of Monokai, I believe). Sep 16, 2015 at 23:29
  • See: gnu.org/software/emacs/manual/html_node/elisp/… If you evaluate this, does the problem disappear? (set-window-fringes (selected-window) 0 0 nil) You could also try adding the following to your .emacs file and restart Emacs: (add-to-list 'default-frame-alist '(left-fringe . 0)) (add-to-list 'default-frame-alist '(right-fringe . 0)) If you like the fringe, you can keep it but change the color to match the 'default background color.
    – lawlist
    Sep 17, 2015 at 0:02
  • No it doesn't. Added it to the end of .emacs, and didn't make a difference. Sep 17, 2015 at 0:04
  • If you get rid of the theme, does your problem go away? The function set-window-fringes operates on the current window when the function is evaluated, not globally. Evaluate means: M-x eval-expression -- so it is not something that is just added to the .emacs file unless you programmatically determine which window is selected when the function gets called during startup. The default-frame-alist is a different story.
    – lawlist
    Sep 17, 2015 at 0:06

1 Answer 1

3

Terminal.app has slight margins on the each end. This works fine for terminal commands, but it also adds an unwanted margin to your "full-screen" terminal applications. I don't think there is any preference to remove these margins in Terminal.app

One solution is to use a patched copy of iTerm2. You can download the source from iTerm2's github repository, and apply this patch. Adjust the margin to your liking.

Another option is to set the Terminal.app background color to match your Emacs theme background color.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.