1

I have YASnippet installed in emacs 24.5, which wasn't working and after a lot of different attempts at a fix, I now have the basics working, however - somewhere along the way - I have collected the following key bindings:

This isn't a question of altering the TABbehaviour (I've seen a lot of threads on that).

When I have yas-minor-mode enabled, I cannot type the letter 'c' at all. Here is what is stored in my YASnippet minor mode keybindings:

Key bindings:
key             binding
---             -------

C-c         Prefix Command
TAB         yas-expand
c           Prefix Command     <---- *
<tab>       yas-expand

c -         Prefix Command     <---- *

C-c &       Prefix Command
C-c k       yas-expand

c - c       Prefix Command     <---- *

C-c & C-n   yas-new-snippet
C-c & C-s   yas-insert-snippet
C-c & C-v   yas-visit-snippet-file

Now I am no expert, but those I have marked look a little too funky.

How can I remove them?

I have tried recreating those bindings and setting them to nil - no joy.

If there is no fix, would deleting the package and reinstalling it solve the issue? I am not sure where those kaybindings are actually stored... ?

  • I like to use key bindings in my snippets, and yasnippet combs the snippet to see if there is a user-defined binding. Perhaps one or more of your snippets have bindings inside them, so you could open them and have a peek for something like this: # binding: TAB r Perhaps you have one that begins with the letter c? The most likely scenario, however, is that you are using someone else's configuration that you have copied where they thought the letter c should be a prefix key instead of being able to type the word candy like a normal person. – lawlist Sep 18 '15 at 3:06
  • Yasnippet has a nifty help table that describes everything: M-x yas-describe-tables -- you may wish to give that a try to see what shows up -- perhaps that will give you some more clues. – lawlist Sep 18 '15 at 3:12
  • I think those key bindings are my mistake - I only installed from MELPA and tried adding a key binding myself - I must have evaluated an incorrect binding and deleted it... don't know how else they could be there as there is nothing shown in the yas-describe-tables - no key bindings or other clues I can find. All very empty. – n1k31t4 Sep 18 '15 at 20:21
  • I've posted a little guide to setting up yasnippet for buffer-local usage or using it on a per major-mode basis, instead of globally: emacs.stackexchange.com/questions/16742/… You may wish to consider reducing your Emacs installation to the bare minimum -- 3 lines of code -- just to get yasnippet working properly, and then slowly add back your own user configuration until you find out where the problem is -- i.e., add back a little, test it, add back some more, test it, and keep going until you find the code that causes the problem. – lawlist Sep 19 '15 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.