1

Today I tried to export an org table by issuing M-x org-table-export <RET> table.csv <RET> <RET>. To my surprise, I received the error message

Symbol's function definition is void: org-export-create-backend

I believe this is happening because of my recent upgrade to org-mode version 8.3.1 from version 7. Any ideas what is going wrong?

1 Answer 1

1

Elsewhere, you'd mentioned you tried installing both the git and ELPA versions of Org.

So that's most likely the problem. You might want to clean up and reinstall Org:

Cleanup

1. Remove the git version of org

You can use make clean-install to remove an org installation from git. If you customized your install location, make sure to use the same settings.

2. Remove the ELPA version of Org.

In list-packages, move point over the Org package, press d to mark it for deletion, then press x to execute the deletion.

Reinstall Org

Pick your favorite way of installing Org, and do that. Either the git version or ELPA version is fine, but the git version is more bleeding-edge. You shouldn't need incredibly new Org for most things, but it will have slightly more features and bugfixes.

4
  • After completing (1) and (2), issuing M-x org-version returns Org-mode version 7.9.3f. This version exports tables fine. Reinstalling org through ELPA then upgrades me to version 8.3.1 and the problem arises again. In fact, this version seems to effect a few other things, like table functions and table importing. Could this be a problem with 8.3.1 itself? Sep 22, 2015 at 6:32
  • And thanks for taking the time to look this! Sep 22, 2015 at 6:32
  • After a lot of googling, I found this stackoverflow.com/questions/22988092/… which ended up working! Sep 22, 2015 at 7:02
  • What exactly did work for you?
    – Christian
    Feb 4, 2016 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.