4

The org-export to beamer gives the following error when the first lines include title and author info.

#+TITLE: Presentation Title 
#+AUTHOR: Name

"Wrong type argument: listp, #("Name" 0 4(:parent (#0)))"

I have used this format many times and don't know why this error is occurring now. Has there been a change in org-export engine? I have reinstalled org-mode(Version 8.3.1) and tried other ways of specifying author and title as in following answers link1

#+BIND: org-latex-title-command "\\title{De leerplandoelstellingen}\n\\date[mei 2014]{9 mei 2014}\n\\maketitle"

and adding the following to the init file as suggested here.

(eval-after-load "ox-latex"

  ;; update the list of LaTeX classes and associated header (encoding, etc.)
  ;; and structure
  '(add-to-list 'org-latex-classes
                `("beamer"
                  ,(concat "\\documentclass[presentation]{beamer}\n"
                           "[DEFAULT-PACKAGES]"
                           "[PACKAGES]"
                           "[EXTRA]\n")
                  ("\\section{%s}" . "\\section*{%s}")
                  ("\\subsection{%s}" . "\\subsection*{%s}")
                  ("\\subsubsection{%s}" . "\\subsubsection*{%s}"))))

Any solutions? Thanks.

  • It would help if you could post the stack trace of the error. To obtain the stack trace do M-x toggle-debug-on-error and try to export again. And while you are waiting for an answer: one of the likely causes of this error is that you have compiled new version of Org together with the bits of the old one, so cleaning up Org versions and recompiling the latest one you have might help. – wvxvw Sep 26 '15 at 20:37
  • @wvxvw Thanks for the reply. The errors vanished after installing Emacs 24.5 with org 8.3.1 inbuilt. But still not getting the title and author info in the beamer. – Anusha Sep 27 '15 at 4:42
  • OK, can you post the preamble of the TeX file generated from your Org file? (That is the text from the beginning of the document and until \begin{document}. The reason I'm asking for this is because it should contain \author[]{...} text where the author would be normally specified. If that doesn't happen for whatever reason you could probably add that to the export template. For the LaTeX syntax to do it see mirrors.ircam.fr/pub/CTAN/macros/latex/contrib/beamer/doc/… page 93. – wvxvw Sep 27 '15 at 12:51
  • @wvxvw Thanks. Your first comment helped me track the problem. If you add as an answer, will upvote. – Anusha Sep 28 '15 at 13:59
3

So it looks like mixed Org installation is to blame. It appears that Org FAQ has something to say on this subject:

Is my Orgmode installation mixed?

Emacs is distributed with a version of Orgmode bundled with it. A common problem among users who install a newer version of Orgmode separately is a mixed install where Emacs loads some files from the bundled and the rest from the latest version. This can lead to unending troubles in the future. With a recent installation of Org mode M-xorg-version will indicate if the installation is mixed.

With somewhat older Org mode installations, the procedure is more involved and indeterminate. An easy first step is to look at the output of M-xorg-version.

  • Good

    Org-mode version 7.8.11 (release_7.8.11-448-g1737d3 @ /path/to/org-mode/lisp/)
    
  • Bad

    Org-mode version 6.33x (release_7.8.11.409.ga3778)
    

A second step is to go through the output of list-load-path-shadows line-by-line to get hints to what in your configuration is causing the issue. Among the most common reasons is Orgmode gets loaded before the load-path variable is updated to include the installation directory of the latest Orgmode. To avoid issues like this, it is recommended that the load path is updated very early on in your init file.

Note: The formatting of the version information, as shown in the examples above, will be different for older Org mode releases, e.g. Org-mode version 7.8.02.

  • OK, so how do you fix this? – Aaron Hall Jun 30 '16 at 3:52
  • @AaronHall the simplest way is to find Emacs' lisp-site directory and remove the Org code from it, or replace it with the code you've downloaded from Org's site. But this is too "hacky" (will require from you to manually update the Org's code every time you want to update Emacs). Another, hopefully simple way to fix this is to specify the directory of your Org installation at the top of your init file and require all org packages you are going to use as soon as you do that. – wvxvw Jun 30 '16 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.