3

I cannot seem to get correctly exported smart single quotes in Org 8.3.

Here is a minimal test.org file:

#+OPTIONS: ':t
#+LANGUAGE: en

This is 'within single quotes'.  This is "within double quotes".

With emacs -Q, org-version reports 8.2.10. The output when exporting to UTF-8 text is:

This is ‘within single quotes’. This is “within double quotes”.

and the output when exporting to LaTeX is:

This is `within single quotes'.  This is ``within double quotes''.

This is what I would expect.

If I load the most recent version of org-mode (starting from emacs -Q, typing M-x package-initialize RET, and M-x load-library RET org RET), then org-version reports 8.3.2, and the output no longer correctly translates single quotes. In UTF-8 text, the result is:

This is ’within single quotes’. This is “within double quotes”.

and in LaTeX, the result is:

This is 'within single quotes'.  This is ``within double quotes''.

Is there anything non-obvious going on with smart quote export in the newer version of Org, or is this simply a bug which I should report?

  • Looks like a bug to me. I suspect it lies in org-export--smart-quote-status. – nanny Oct 1 '15 at 20:31
  • You can do M-x org-submit-bug-report – nanny Oct 1 '15 at 20:36
  • any update on this? could you post a link to the bug report? – Mark Dec 31 '15 at 15:53
  • @Mark I know this is several years later, but for people how arrive here by searching for this, let me say than Jon did post to the mailing list and was told that there was a change in Org mode: it was decided that single quotes would only export smartly when they were nested inside double quotes. (So it's not a bug but a conscious choice.) – Omar Jun 27 at 2:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.