1

After struggling with AUCTeX installation under Windows, I was suggested here to use ELPA and its automatic process to install the package.

Following this, everything went fine and I can now read, process, and export to pdf a .tex source within emacs.

Also, I have available the dvipng program and I can successufully reproduce the steps described here in the section dvipng setup.

However, it is the latex-preview mechanism which I cannot get to work. Different things happen in org-mode and AUCTeX:

AUCTeX :

After finding a .tex file, Preview, LaTeX and the rest of menus are available, and as said the process of generating a dvi and pdf flows without issues. However, the preview on toggle does not work correctly. I get the following error message:

LaTeX: preview-image-type setting 'png unsupported by this Emacs

I looked up the specific error string and got here, where it is suggested to change the output format from png to pnm in the preview-latex.el file. However, I cannot find this file!!!

org-mode :

I insert a LaTeX fragment into an org file (an equation), then with C-c C-x C-l I should have a preview of the output overlayed inline, but I do not see any change in the buffer. Still, I get no error message even if the variable org-format-latex-signal-error is set to non-nil (which should signal an error in image snippet creation). All I see in the minibuffer is the message:

Creating image...done. Use `C-c C-c` to remove images.

EDIT

I made the AUCTeX preview work...it involved downloading of dll and correction of launching command for - basically - ghostview. There are few steps involved, so I plan to write about them as soon as I have a minute.

org-mode preview does not work as of yet, it just shows a white image so I'll have to investigate that.

  • Take a look at tex.stackexchange.com/questions/262959/… The problem about unsupported png format is addressed also in AUCTeX manual. To change a value of a variable, you don't need to edit the original source but you can do it also in your init file – giordano Oct 3 '15 at 22:51
  • I don't know...I've been adding .dlls, installing ghostview although this is already available in my MiKTeX installation, trying to change to pnm instead of png...Nothing works. – Mike Anblips Oct 4 '15 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.