9

Comparison of emacs -nw vs emacs with GUI

On the left: emacs in console mode. On the right: emacs with GUI.

Running 24.5.1 on Arch linux. Both my console and emacs have the font set to Inconsolata 12. What can I do to make the emacs with GUI fonts look "smoother"?

[ETA more detail:]

I tried making a /etc/fonts/local.conf file which specified anti-aliasing. It made no difference. (I'm not using Infinality.)

According to this answer I should find out the GNOME settings and make a .Xresources file that emacs would use. But I didn't have any luck there.

From gnome-tweak-tool I had:

  • Hinting: medium
  • Antialiasing: Grayscale
  • Scaling Factor: 1.0

I couldn't figure out what "Antialiasing Grayscale" is equivalent to in Xresources-speak...

$ xrdb -query | grep Xft
Xft.dpi:    96
Xft.antialias:  1
Xft.hinting:    1
Xft.hintstyle:  hintmedium
Xft.rgba:   none

This is what was there before I made a .Xresources file and it seems basically correct? I tried changing Xft.rgba to rgb but I couldn't appreciate any difference.

0

I'm not too sure about how to apply these settings, but your desired settings seem to be at odds with your picture. The one on the left (your preferred one?) has RGB antialiasing and none-low hinting, whereas on the right you have grayscale antialiasing and much higher hinting (zoom the picture until you see the individual pixels to see what I mean).

So your GUI emacs is obeying your .Xresources, and the terminal emulator is doing its own thing.

To recreate the settings for the picture on the left, you should go with:

  • RGB antialiasing
  • low or no hinting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.