0

When I increase the default font size (say, from Menlo 12 to 14), either by Options->Set Default Font or by (set-face-attribute 'default nil :height 140), the top of the buffer becomes hidden. The visible part of the buffer starts a few lines down (depending on font size) and the actual top is hidden above the top of the window. I can move the cursor up to the top of the buffer, but it disappears above the window. M-x beginning-of-buffer doesn't help. If I lower the font size, it becomes visible again.

Emacs 24.5 (9.0) on OS X Yosemite (10.10.5)

  • Sounds like a bug. If you can reproduce it when you start Emacs from emacs -Q (no init file) then consider filing a bug report: M-x report-emacs-bug, providing a step-by-step recipe. – Drew Oct 7 '15 at 22:18
  • Thanks, Drew, I'll do that. It is easily reproducible (even though I did find a workaround -- see, below). – Phil Mitchell Oct 7 '15 at 22:23
  • Turns out it's a known bug: debbugs.gnu.org/cgi/bugreport.cgi?bug=21016#5 – Phil Mitchell Oct 7 '15 at 22:29
1

Turns out this was due to a conflict with setting frame size:

(setq default-frame-alist '(
               (width . 150)
               (height . 52) ))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.