0

If you type C-c C-k (to abort a capture process, for example), you get a C-c C-v instead. It's like for this particular shortcut combo, Emacs interprets the hard key codes instead of the Dvorak layout on top (FYI: pressing v on a standard keyboard produces the key k with the Dvorak layout). I think the problem lies with Emacs since even the mini buffer shows it as C-c C-v. At any other time, my k key works just fine on its own (including any other shortcut other than C-c C-k C-k generally trenslates to C-v).

Have any other Dvorak user encountered this problem? How did you fix this? I want to make sure I'm not the only one, because if I am, it is probably not a bug.

I'm on Emacs 24.5.1.

Update: I just noticed an old piece of Autohotkey script that was mapping Ctrl+k to Ctrl-v. So the problem was Emacs unrelated.

  • 2
    Do you see the same behaviour when starting Emacs like this: emacs -q? If not, this is related to your settings. I'm using Dvorak as well and cannot reproduce this. – rekado Oct 8 '15 at 19:09
  • It might also be related to how your computer is set up to use Dvorak. Are you using an OS setting? A registry remap? A keyboard with levers to press the QWERTY buttons? – zck Oct 8 '15 at 21:02
  • @rekado: Same behavior with -q. – Certainly Oct 8 '15 at 21:07
  • 5
    @Certainly The convention used on stackexchange is to mark an answer that resolves your problem as Accepted. So instead of editing the title with "SOLVED", you should answer your own question and accept it after 48 hours. – Kaushal Modi Oct 8 '15 at 21:29
  • 2
    @Certainly The first step is to submit your own answer. The 48 hrs wait time is after that. :) – Kaushal Modi Oct 9 '15 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.