5

I want to use this theme: https://github.com/jonnay/emagicians-starter-kit/blob/master/themes/org-beautify-theme.org

I installed it via list-package successfully.

I tried loading it via load-theme RET org-beautify RET but it says Unable to find theme file for org-beautify. So I add ~\.emacs.d\elpa\org-beautify-theme-20150106.956 to my 'custom-theme-load-path and do the load-theme thing again, this time it says Undefined custom theme.

How can I activate the theme?

Seeing as someone marked my thread as a duplicate: my custom-theme-load-path does not reset after calling load-theme. You can see that after setting custom-theme-load-path to the location of the file, calling load-theme RET org-beautify RET does not give the response Unable to find theme file... anymore. Instead, I get an error of a different sort ("Undefined custom theme"), which makes me think that I'm not installing it properly. Why can't I choose the theme from Options->Customize Emacs->Custom Themes in the first place after installing it with melpa?

  • It looks like this is an error in the package itself. I propose a few ways to fix it below. I wonder if whoever packaged this up for MELPA even tried installing it. – nispio Oct 9 '15 at 18:06
2

It looks like the author of the theme is using org-babel to invoke the theme, rather than the M-x load-theme. The way that custom themes usually work is that there is a theme named foo within a file called foo-theme.el. In the case of org-beautify, the actual theme is called org-beautify-theme when it should just be named org-beautify.

There are two ways to fix this problem:

  1. Within the file org-beautify-theme.el there are three references in code to org-beautify-theme. Change all of those to org-beautify
  2. Rename the file org-beautify-theme.el to org-beautify-theme-theme.el

I would recommend that you contact the author so that the problem gets fixed upstream.

  • nispio, thank you for getting to the root of the problem. I tried the other suggestions, and while it did work for other themes, it did not work for this particular one. Now I know why. I went with option #2, by the way. It's working nicely now. Thank you. I contacted the author about the problem. – Certainly Oct 9 '15 at 18:10
  • It did not do the magic for me. I do not know where it went wrong :-( – Prasanna Aug 3 '16 at 4:29
  • @Prasanna The numbered items in the answer are an either/or. Do either 1 or 2, but not both. Is that the problem? – nispio Aug 3 '16 at 17:05
  • I understood. But both the options did not do any trick. – Prasanna Aug 3 '16 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.