0

Setup:

GUI version GNU Emacs 25.0.50.1 (x86_64-w64-mingw32) of 2015-07-25 on KAEL

Compiled from EmacsW64.

Direx, using the latest version of Direx from MELPA

Windows 7 x64 bit.

Situation:

I would like to try the package Direx, but the documentation is not very clear.When I installed Direx, I try to start it wih M-x Direx:jump-to-directory but I get a unclear message:

cl-call-next-method: cl-call-next-method only allowed inside primary and around methods

When googling around, I found this thread but it's difficult to understand how this error occured in a package. It's more related with common Lisp than the package itself, it seems.

When I tried again with the empty Emacs configuration (emacs -q), I still get the same message. It's unclear to me what I do need to solve this error, in order to get Direx working.

Direx is downloaded more than 10.000 times ,but I don't know how I could call Direx. The commands for Direx seems obfuscated to me. Seems I am the only one with this bug?

Any suggestion would be appreciated.

7
  • 2
    If you don't get an answer here, consider contacting the package author. (A priori, this sounds like a bug.) – Drew Oct 16 '15 at 19:25
  • 2
    It' s a bug in direx.el where the code calls cl-call-next-method inside an EIEIO method (they should either switch to a cl-generic method, or use EIEIO's call-next-method). – Stefan Oct 17 '15 at 17:02
  • You're getting the same bug? Direx is downloaded more than 10.000 times ,but I cannot activate Direx. Seems im the only one with this bug? – ReneFroger Oct 23 '15 at 20:08
  • It's a recent regression (for which I am responsible). I have opened a new pull request with the fix: github.com/m2ym/direx-el/pull/48. (I switched to cl-call-next-method in the wrong commit "switch to cl-lib" instead of in "use cl-defmethod, not for immediate merging".) – tarsius Oct 23 '15 at 21:08
  • Once that has been merged, you should probably delete this question, because I am not going to provide an answer to claim the extra 50 - that wouldn't seem right. – tarsius Oct 23 '15 at 21:11
0

It seems it was a bug in Direx which was fixed by @tarsius, my thanks to him. So I consider this issue as being closed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.