1

I've got the following configuration set up for displaying my current agenda and tagged todo items:

  (setq org-agenda-custom-commands
        '(("g" "Plan today"
           ((agenda "")
            (tags-todo "Computer")
            (tags-todo "Online")
            ...
            )
           )))

When called with C-c a g this shows the agenda for the current week. I can switch to the current fortnight using v t which is org-agenda-fortnight-view, but when calling the agenda again, it switches back to week view.

What should I do to make the fortnight-view the default?

2

The related questions section here on SO actually provided me with a pointer to the solution, which is to set the org-agenda-span variable/option like so:

 (setq org-agenda-custom-commands
        '(("g" "Plan today"
           ((agenda "" ((org-agenda-span 14)))
            (tags-todo "Computer")
            ...
            )
           )))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.