0

After upgrading to emacs 24 I have strange problems with copy and paste. I managed to reinstall copy and paste with the mouse but there remains the problem with German diacritic characters. If I copy an Umalut äöü and insert it using the mouse (middle button) I get unicode stuff that cannot be saved \344\366 and so on. Is there a way to fix this?

  • 3
    You'll need to give us more information. What operating system are you using? What Emacs binaries are you using? Do you have the same problem if you start emacs -q? If so what about emacs -Q? Do you have this problem when copying and pasting within the same buffer, between different buffers, or only between Emacs and some other application? – Gilles 'SO- stop being evil' Nov 29 '15 at 12:18
1

This bug (debbugs#20906) has been fixed in the emacs-25 branch. The fix will be effective in the next stable release of emacs (as of writing this on May 27, 2016).

To get that fix earlier, you can try out the latest available pre-test for emacs 25.1.

0

Probably not related to a certain version: Emacs needs some info WRT coding-system. Fails sometimes with some known OS. Check setting of coding-system-for-read. Sometimes copy-and-paste into another buffer helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.