2

When I try to start Emacs I get the following warning:

symbol's function definition is void: slime-face-inheritance-possible-p

This happens most of the time, only sometimes it seems to work. If I remove all installed packages (package.el) and install them again, then it works fine on the first start, but not on subsequent starts.

I'm using the packages slime, slime-repl and slime-company.

3

According to commit 2e5538a the long deprecated function slime-face-inheritance-possible-p has been removed from slime in May 2015.

You probably installed the package slime-repl via marmalade, where it is currently listed as version 20100404, e.g. being from 2010 and thus very old.

As of now (October 2015) the package slime also contains the slime-repl.el in the contrib folder, and thus supports the slime-repl out of the box (after enabling it via slime-contribs). To solve the issue just remove the obsolete package slime-repl.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.