0

After switching to gui version of emacs and also installing prelude with helm everywhere, I have lost the ability to paste stuff in to the search prompt.

So before, I could mark a word, copy to clipboard and C-s (I-search) and then Command-V would paste whatever was in the clipboard in to the I-search prompt. This doesn't happen anymore. Any ideas?

  • 1
    Use C-s C-h b to view all the key bindings for isearch-mode. See if cmd+v is in there somewhere, maybe it's getting overshadowed. In the meantime, you can use C-y to yank things from the clipboard as well. – nanny Nov 2 '15 at 13:51
1

Essentially, you've said that you have a whole lot of stuff in a sack, and something changed somewhere, and the resulting behavior changed. And you're asking for help removing that behavior change. That's all pretty nebulous. (What is "guy version of emacs"?)

  1. Please provide a succinct, step-by-step, minimal (or close to it) recipe to reproduce the problem. Describe what you see and what you expected to see instead. This question risks being closed because it is unclear.

  2. To narrow down the problem, for yourself or for us to help you better, recursively bisect the giant sack that is your init file. Start by commenting out 1/2 of it, then 3/4, 7/8, 15/16, 31/32, 63/64,... until you have something that approaches a minimal startup that shows the problem.

    You can use command comment-region to comment out selected text (or, with C-u, to uncomment it).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.