1

When I set the core.editor="emacsclient -nc", after I press "C-c C-c" in the .git/TAG_EDITMSG buffer, I got the error message:

fatal: no tag message?

But here is the content of .git/TAG_EDITMSG file

test

#
# Write a message for tag:
#   v0.0.5
# Lines starting with '#' will be ignored.

I have tried to set core.editor to emacs or gedit -s, they all work fine. TAGS are created.

Emacs: compiled from git commit "ecb069e" Git : 2.6.2 OS : Ubuntu 14.04

3

Remove the -n flag. Git expects the editor to block and -n tells Emacs not to block. Hence git tries to use the tag message before you even had the chance to write anything.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.