1

I'm using SSH to connect to remote server. On the server, I'm running emacs (emacsclient -c). It servers as my console, text editor and WM. While everything works nice when I'm not dealing with cyryllic, when I'm to work with cyryllic letters, it gets bad.

I have a file, let's call it x, with "Юра" string in it. If I cat the file from console(without using Emacs), I get proper output. However, if I open it in Emacs, or cat it from ansi-term, I get the following output:

\u042E\u0440\u0430

Now that's obviously not something I want. How can I make Emacs display the cyryllic?

locale is the same both under ansi-term and the terminal Emacs's running in(the one where russina letters are displayed correctly).

  • What is the output of locale? – Gilles Nov 9 '15 at 22:12
  • @Gilles - LANG=en_US.UTF-8, LANGUAGE=EN_US Rest is set to C. – MatthewRock Nov 10 '15 at 11:16
  • LANGUAGE=EN_US doesn't look right (LANGUAGE should be unset, it's only useful if you have multiple settings there, and even if it's set it should probably be set to en_US.UTF8), but I can't reproduce that behavior with these settings. Do you have the same problem if you start Emacs with emacs -q? Does the problem occur only with emacsclient or does it also occur if you run a new Emacs session? What is the version of Emacs and where was it installed from? – Gilles Nov 11 '15 at 0:22
2

I solved my problem by changing LC_ALL to en_US.utf8:

export LC_ALL=en_US.utf8

then, I opened emacs again. Voila, I can see everything clearly now. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.