3

My flymake configuration

;; flymake
(require 'flymake-cursor)  ;; Hoover over error to show help message

;; use pyflakes for Python
(when (load "flymake" t)
  (defun flymake-pyflakes-init ()
    (let* ((temp-file (flymake-init-create-temp-buffer-copy
                       'flymake-create-temp-inplace))
           (local-file (file-relative-name
                        temp-file
                        (file-name-directory buffer-file-name))))
      (list "pyflakes" (list local-file))))

  (add-to-list 'flymake-allowed-file-name-masks
               '("\\.py\\'" flymake-pyflakes-init)))

(add-hook 'find-file-hook 'flymake-find-file-hook)

(add-hook 'python-mode-hook 'flymake-mode)

It works fine locally but breaks when I try to edit files remotely. I have no intention of fixing that, I'm almost not using it, how can I disable it?

Thanks!

2
# -*- eval:(flymake-mode-off) -*-

I use this as a file local variable for remote files.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.