2

I want to have no underlining on highlighted matching brackets. I've done the following to achieve that:

M-x customize-face
show-paren-match

And there I deactivated the underlining of matching parenthesis. However, when I restart emacs the underlining in that same setting is checked again. It seems I can't turn it off forever by changing it this way.

How do I turn it off?

If you look at this screenshot, you can see some teal underlining below the brackets:

enter image description here

It's also in other files, not only on that settings buffer. In my init file I already have these lines:

 '(cursor ((t (:background "gold" :foreground "#151718"))))
 '(show-paren-match ((t (:background "yellow green" :foreground "black"))))
 '(show-paren-mismatch ((t (:underline (:color "#CE4045" :style wave))))))

So I do want a red wave below brackets, which have no counterpart, but none on the matching ones.

  • I don't understand. I want to change the colors of them, so I need to fiddle with the configuration for that, be it in the buffer for their settings or in my init file. I do not want to disable the highlighting completely. Merely the underlining is annoying me. How can disabling help with that? – Zelphir Kaltstahl Nov 21 '15 at 13:53
1

I found a solution that seems to work:

enter image description here

Instead of unchecking the attribute underline, it seems, that it needs to be checked, but set to Off. I also changed other settings for the brackets, which you can see in the screenshot.

  • 1
    It should not be necessary to do that. It should be sufficient to uncheck Underline. Face definitions with that attibute unchecked do not have underlines, normally. Consider filing a bug report: M-x report-emacs-bug. – Drew Nov 21 '15 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.