2

I'm new to org-mode. I've tried to set up a simple TODO list by calling org-capture and when I select my [t] todo item on *Org Select*, Emacs freezes and I need to kill its process.

On the mini-buffer I can read the following error message:

Clipboard pasted as level 2 subtree

Error in post-command-hook (linum-update-current): (args-out-of-range 1 1)

I've updated all packages to the latest version, and reinstalled the latest Emacs 25, but the error persisted. Does anyone have an idea where this might be coming from? Am I overseeing something very simple?

Thanks a lot.

In case this is important..

on init.el:

(setq org-capture-templates
       '(("t" "todo" entry (file+headline "/Users/dgomez/todo.org" "Tasks")
          "* TODO [#A] %?")))

GNU Emacs 25.0.50.1 (x86_64-apple-darwin15.0.0, NS appkit-1404.13 Version 10.11.1 (Build 15B42)) of 2015-11-25

  • A "freeze" could mean different things. Consider reporting a bug, providing a step-by-step recipe that starts with emacs -Q (no init file): M-x report-emacs-bug. Note too that you are using a development snapshot, and those are generally unstable - anything goes. – Drew Nov 26 '15 at 15:08
  • Thanks for the feedback. I found out that the problem is a conflict between linum-mode and org-capture. My question is, should I report this? And who do I report it to? – dangom Nov 26 '15 at 16:36
  • 1
    M-x report-emacs-bug. That will gather info about your session (which you can edit, if you want). C-c will prepare the report to be emailed. Try to provide a minimal step-by-step recipe, from emacs -Q. – Drew Nov 26 '15 at 20:43
2

I had (global-linum-mode 1) on my init.el, and that conflicts with org-capture somehow. I've changed it to (add-hook 'prog-mode-hook 'linum-mode) and the issue was gone.

Apparently linum-mode is not compatible with org-capture.

1

Yep, I ran into the same problem. org and linum are somehow incompatible.
As a different solution you can also use a hook and simply disable linum-mode when org is the major mode.
I also do this for drag-stuff since it violates org-mode's shortcuts.

(add-hook 'org-mode-hook 
          (lambda () 
            (drag-stuff-mode -1) 
            (linum-mode -1)))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.