0

This box appears in the center of my Emacs frame with certain actions.

The most reliable way to trigger it is attempting to move the cursor past the boundaries of the buffer.

It disappears after switching to a different buffer, or scrolling enough to replace all the text in view. Marking the area also solves it.

I don't think it's an accessibility feature because of the unusual way in which it disappears. Anyone else recognize this?

Thank you!

My version: GNU Emacs 24.5.1 (x86_64-apple-darwin15.0.0, NS apple-appkit-1404.13) of 2015-11-30

Installed with Macports on El Capitan

enter image description here enter image description here

  • 1
    I think that's the ding ding . . . bell bell -- Google a bit for emacs ding bell and you'll find several threads on the issue and how to turn it off. – lawlist Dec 2 '15 at 5:27
3

It's a known bug in Emacs, when running on El Capitan.

You can avoid this by setting visual-bell to nil (in which case Emacs beeps instead) or ring-bell-function to a function of your choice. If you want Emacs to be quiet, you can set it to ignore.

This has been fixed in the upcoming Emacs 25.

  • Could be wrong, but I thought I encountered it in Yosemite as well. I was running Yosemite until last Wednesday. – Peter Becich Dec 2 '15 at 18:17
  • I have never heard of anyone experiencing this in Yosemite. Pity you don't run it any more, it would have been good to know if this was the case, and, if so, to get a recipe for how to reproduce it. – Lindydancer Dec 2 '15 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.