0

I'm using PrivateInternetAccess for my proxy and when I enable it, sending email via mu4e times out (although retrieving emails works fine). With the proxy disabled, sending works fine.

Here's a screenshot of my PIA settings:

enter image description here

And how my account is defined:

(defvar my-mu4e-account-alist
  '(("personal"
     (mu4e-sent-folder "/personal/[Gmail]/Sent Mail")
     (mu4e-drafts-folder "/personal/drafts")
     (user-mail-address "foo@gmail.com")
     (smtpmail-smtp-user "foo@gmail.com")
     (smtpmail-default-smtp-server "smtp.gmail.com")
     (smtpmail-smtp-server "smtp.gmail.com")
     (smtpmail-stream-type starttls)
     (smtpmail-smtp-service 587)))

Is this a problem with the proxy? My settings (emacs or PIA)?

1

This seems an issue with PIA. By default they restrict SMTP access through their service to avoid SPAM abuse. You can contact their helpdesk to allow access to gmail from your account:

In order to have your SMTP server white listed, please submit a ticket via the following link (or emailing helpdesk@privateinternetaccess.com):

https://support.privateinternetaccess.com/index.php?/Tickets/Submit

Include the name of your SMTP server (smtp.gmail.com for example) and the IP address (74.125.136.109 for example) for the server. To get the IP address for the server, go to http://ping.eu/ping/ and put your email server in the box there, and click the black Go button. This will ping the server four times, then stop. Copy the IP address for the server, and include it in your ticket.

Source: PIA Knowledgebase

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.