2

I am using wgrep but somehow for those read-only files (under version control), it always reports not to apply changes. Even the var of wgrep-change-readonly-file is set to t. Any idea how to fix it?

3

The Github README says that the variable actually means read-only buffers, not read-only files:

To apply all changes wheather or not buffer is read-only.

(setq wgrep-change-readonly-file t)

You cannot modify read-only files by definition. You must adjust the files' attributes in order to do so. This varies depending on your operating system and file system.

2
  • I tried to open them in advanced, but it still does not work and can not change the read-only property of these buffers. Are these steps correct?
    – macs
    Dec 3 '15 at 4:43
  • @macs I just tried it out, and it works fine.
    – nanny
    Dec 3 '15 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.