0

I want to open a python interpreter in a buffer with ipython. So I use that, from the term-mode :

(make-term "ipython" "/usr/bin/env" nil "ipython" (or filename "")
           "--TerminalIPythonApp.force_interact=True"))

But I don't know where to precise the python version that I want to use : my default version is python2.7 and I want to start an interpreter with python 3.4.

-1

The solution was :

(make-term "ipython" "/usr/bin/env" nil "ipython3" (or filename "")
   "--TerminalIPythonApp.force_interact=True"))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.