2

I installed the Solarized theme through package-install RET solarized-theme, and it went largely well but .org files have a strange appearance:

enter image description here

Note how it hides the line numbers. Here is how it looks on other files:

enter image description here

How do I make it so that org files have the same appearance as other files? Please note that I am new to this so I may not understand some things that are obvious to more experienced Emacs hackers.

My init.el file:

(package-initialize)

;;settings files location
(add-to-list 'load-path "~/.emacs.d/settings")
(add-to-list 'load-path "~/.emacs.d/elpa/")
;;import settings from other files
(require 'general-settings)

;;theme loading
(add-to-list 'load-path "~/.emacs.d/elpa/")
(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(custom-enabled-themes (quote (solarized-dark)))
 '(custom-safe-themes
   (quote
    ("8aebf25556399b58091e533e455dd50a6a9cba958cc4ebb0aab175863c25b9a4" default)))
 '(inhibit-startup-screen t)
 '(package-selected-packages (quote (solarized-theme))))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 )
(load-theme 'solarized-dark t)
;;ido
(require 'ido)
(ido-mode t)(package-initialize)

(setq package-archives
      '(("gnu" . "http://elpa.gnu.org/packages/")
       ("marmalade" . "http://marmalade-repo.org/packages/")
       ("melpa" . "http://melpa.milkbox.net/packages/")))

;;org-mode

;;markdown
(autoload 'markdown-mode "markdown-mode"
   "Major mode for editing Markdown files" t)
(add-to-list 'auto-mode-alist '("\\(.text\\|.markdown\\|.md\\)'" . markdown-mode))
(setq markdown-enable-math t) ;;enables math functions

my settings file (some useful things I borrowed from a friend):

;;------------------------------;;
;;   Global Editor    Settings  ;;
;;------------------------------;;

(setq current-language-environment "English") ;; Language
(setq inhibit-startup-screen t) ;; Don't show the start-up Screen

(menu-bar-mode 0) ;; Toggle menu bar

(require 'tool-bar) ;; Toggle toolbar
(tool-bar-mode 0)

(global-hl-line-mode 1) ;; Highlight line with cursorx

(if window-system (scroll-bar-mode 0)) ;; Toggle scroll bar
(require 'mwheel) ;; Toggle mouse wheel support for scrolling
(mouse-wheel-mode 1)

(transient-mark-mode 1) ;; Transient-Mark Mode (highlight selection

(global-linum-mode t) ;; Display line number at left
(line-number-mode 1)
(column-number-mode 1)

;; Text decoration


;; Window resizing bindings
(global-set-key (kbd "S-C-<left>") 'shrink-window-horizontally)
(global-set-key (kbd "S-C-<right>") 'enlarge-window-horizontally)
(global-set-key (kbd "S-C-<down>") 'shrink-window)
(global-set-key (kbd "S-C-<up>") 'enlarge-window)


(provide 'general-settings)
1

For those with this problem, I solved it as follows:

Solarized theme has a toggle to scale font sizes of org headings. Disable that with this line in the init file to fix the issue:

(setq solarized-scale-org-headlines nil)
  • Did you try nlinum instead of linum for line numbers? – lunaryorn Dec 4 '15 at 9:07
  • 1
    For me, the font used in the headings is still different. Would be nice to be able to prevent that too. – Toothrot Aug 15 '16 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.