2

I recently started having an issue. I am unsure as to how long it has existed, but it must have occurred during the past week. Whenever I type Shift-c, Emacs does not interpret it as the character C, but rather the Control command. This acts only in the outline minor mode (regular outline mode is unaffected). I am unsure if this is a component of the mode, or a bug somewhere

  • 1
    Please try without your init file via emacs -Q. If the problem goes away, bisect your init file until you isolate the problem. If the problem persists, it's because of some setting at the OS level. – Dan Dec 5 '15 at 14:08
5

I had the same problem with outline-minor-mode and the following line in my init.el was the culprit:

(setq outline-minor-mode-prefix "C-c C-o") 

Seems like that was interpreting the first "C" as Shift-C instead of Control.

  • 3
    That's probably because you need to wrap "C-c C-o" in a call to (kbd ...). – Dan Mar 11 '16 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.