0

I'm using the Anaconda distribution for Numpy, Ipython etc. and during the installation the following was added to my .bashrc:

# added by Anaconda2 2.4.0 installer
export PATH="/home/matthias/anaconda2/bin:$PATH"

when I run M-x shell in emacs "ipython bla.py" works perfectly fine. However, when I run M-x compile and then enter "ipython bla.py" it will say:

ipython bla.py
/bin/bash: ipython: Kommando nicht gefunden.

Compilation exited abnormally with code 127 at Tue Dec  8 13:35:59

How do I tell emacs about my anaconda installation, like I did in .bashrc?

1

You should move $PATH to ~/.profile. .bashrc is only for interactive sessions; variables in this file do not propagate to GUI applications.

Once you moved the setting, restart your system, and Emacs should see your new $PATH.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.