3

I can send mail with message, via C-x m. However, when I try to send a message from Gnus, via m in the summary buffer, or other commands like S r, F etc, the message shows up in my sent folder in Gnus, but doesn't actually get sent. i.e., everything appears to work as expected from Gnus, no errors are generated, but the recipient doesn't get the email.

Do I need to do something specific to configure Gnus to send mail? I have the following config which appears to be sufficient for message:

(setq gnus-select-method
      '(nnimap "<my-mail-server>")
       send-mail-function 'smtpmail-send-it
       smtpmail-smtp-server  "<my-mail-server>"
       smtpmail-stream-type  'ssl
       smtpmail-smtp-service 465)
  • Have you tried (setq message-send-mail-function 'message-send-mail-with-sendmail) ? – politza Dec 11 '15 at 19:47
  • @politza No. I don't have sendmail set up, but I can take a look at that when I get back to my home computer. – Tyler Dec 11 '15 at 21:39
  • I guess, I misread. – politza Dec 11 '15 at 21:48
0

I think I found a solution. The customization variable message-send-mail-function was set to message-send-mail-with-sendmail. My configuration (in the question above) appear to have over-ridden this when sending mail from message, but not when sending/posting mail from gnus. Somewhere in the posting process I think gnus was querying the function message-send-mail-function, which returned the value of the message-send-mail-function variable, which was wrong.

Setting message-send-mail-with-function to smtpmail-send-it seems to have fixed this problem. I suspect the ultimate source of the problem is that sendmail was installed on my machine but misconfigured. Emacs detected this and set the default values based on that. Maybe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.