3

I am running Emacs 24.5.1 (compiled) and Spacemacs v.0.105.4 on Ubuntu 12.04.

When I try to use the spotify layer I get the following error: peculiar error: "Emacs not compiled with dbus support".

How do I fix it?

  • 1
    It looks like your version did not get compiled with dbus support. Not sure what version is in the Ubuntu repositories, but if you pulled it from there and are getting this message, you may need to compile from source instead with the dbus option enabled (see the manual and Xah Lee's page for information on doing so). – Dan Jan 7 '16 at 14:53
  • And by the way, your Ubuntu install is nearly 4-years old. You may want to think about upgrading. – Dan Jan 7 '16 at 14:54
  • company policy, need to work on this platform . – Nicolas Torres Jan 8 '16 at 15:06
4

Found the solution: I was missing the package libdbus-1-dev. After ./configure && make dbus support was automatically added. So basically follow:

sudo apt-get install libdbus-1-dev
./autogen.sh
./configure
make

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.