I've been successfully using org2blog for awhile, but it has stopped working in recent days. When I try to log in from emacs, org2blog asks my password as always. I provide it, and the process fails with

xml-rpc-request: Error during request: 403

I can still log in to my account from my web browser, so it doesn't appear to be on that end. Here's my init.el lines for org2blog:

;; * org2blog 
(require 'org2blog-autoloads)
(setq org2blog/wp-blog-alist
      :url "http://stevenarntson.com/xmlrpc.php"
      :username "stevenarntson"
      :tags-as-categories nil)))

What is wrong here, or, alternatively, what next step should I take to diagnose this?

emacs 24.5.1

org 8.3.2

org2blog .9.2

xml-rpc 1.6.11

1 Answer 1


Something may have changed in your Wordpress config with respect to XML-RPC.

Opening the xmlrpc.php page in a browser is giving a 403 instead of a GET not allowed response.

See https://testorg2blog.wordpress.com/xmlrpc.php vs. http://stevenarntson.com/xmlrpc.php in a browser.

  • I finally resolved this---my hosting service had changed some security settings. They say they have "whitelisted" the request I'm making to remotely post to my blog, and now everything is working again. Commented Jan 24, 2016 at 4:04
  • For me this issue was solved by turning my vpn service off. I hope this information turns out to be helpful.
    – Ajned
    Commented Jul 13, 2020 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.