0

I'm not sure this is specific to helm, but when in helm's helm-ucs (C-c h 8) (though this also happens with helm-unicode), I notice that some characters show the weird little box glyph as if the character can't be rendered, but then when I actually "select" them in helm, they do render. This seems very curious, and so I myself am curious as to what could be causing this.

In the following example, consider the character RIGHTWARDS ARROW WITH NOTCHED TAIL, though this happens with all of the other characters that show boxes.

Not selected:

not selected

Selected:

selected

  • 2
    A shot in the dark: different font-faces in action. One of them has unicode glyphs, the other doesn't. And they switch when you interact with the text. – wvxvw Jan 12 '16 at 14:38
  • 2
    What @wvxvw said - one font supports the char; another doesn't support it. – Drew Jan 12 '16 at 14:41
  • You can easily check whether this is Helm-specific, and if not, remove that part of your question (and tag helm), to simplify it. Try just inserting the same character into a buffer (that uses the same font) using C-x 8 RET. E.g., C-x 8 RET rightwards arrow with notched tail RET. – Drew Jan 12 '16 at 14:42
1

Thanks Drew and wvxvw. I'm convinced you guys are correct, although I don't think I can prove it anymore. It confounds me, but somehow after restarting emacs a couple times in between changes to my init.el (with no even remotely font-related changes), this behavior changed so that even when I selected the candidate it still showed the box.

So I went to my font-related configuration and noticed that somehow I had this:

;; Incorrect code below!
(cond
 ((eq system-type 'darwin)
  (set-fontset-font "fontset-default" nil "Symbola" nil 'append))
 ((eq system-type 'gnu/linux)
  (set-fontset-font t 'symbol (font-spec :family "Apple Color Emoji") nil 'prepend)
  (set-fontset-font t 'symbol (font-spec :family "Apple Symbols") nil 'append)))

Somehow my OSes there were flipped, so I wasn't setting Symbola even though I'm on linux. I fixed that and now everything is perfectly fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.