2

Tonight I started Emacs, and helm-mode is no longer used for certain actions. So far I have found that, for me, M-x and find-file don't use helm anymore, which they have since I first started using helm. I can clearly see Helm displayed in my mode-line, but when I hit M-x or C-x C-f, Helm disappears from my mode-line.

For me these have always worked automatically, I haven't configured these commands to use helm explicitly. Other commands continue to use helm, e.g., describe-variable and describe-function still use helm for completion.

Normally, I would assume that I messed up my configuration file or that an update to helm changed something. However, all my configuration files are under version control, and nothing has changed. Also, I think I might have updated helm yesterday through MELPA, but I can't imagine that I would have gone all day without using find-file or M-x without noticing that they had changed. Also, on the helm github page, I cannot see any indication that these things have been changed recently.

Starting Emacs with the -Q option to bypass my init file, activating packages with package-initialize and running M-x helm-mode to activate helm gives me the same results: helm completion is used for e.g., describe-variable and describe-function, but not for M-x or find-file other commands might be affected as well, but this is what I have found so far. Is anyone else experiencing this behavior? Does anyone know what is going on?

To be clear, helm-find-files and helm-M-x commands still work, so I could bind them to C-x C-f and M-x, but I am curious what happened, to the previoius behavior.

  • As your configuration is under version control, you can trivially revert your package update, and compare. – phils Jan 14 '16 at 8:10
  • @phils my packages are the one thing that is not under version control, but I will probably be changing this now. – elethan Jan 14 '16 at 12:50
2

Yes, this is done in this commit by the helm maintainer to reduce confusion for new users, if you want the old behaviour, just undo that commit by customizing helm-completing-read-handlers-alist.

  • Haha, yeah...the commit message is: "Unhelmize find-file and M-x by default to avoid confusion." I actually scanned the changes in the code of the commit right before that, and then stopped looking. Thanks! – elethan Jan 14 '16 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.