3

I would like to use org to type my math lessons, documentation says it has an embedded system completion which can be activated by :

(add-hook 'org-mode-hook 'turn-on-org-cdlatex)

This command is not present on my system (emacs 24). There is still an org-cdlatex-mod but when I trigger it with M-x it says

Cannot open load file: no such file or directory, cdlatex

After what if I retrigger the mod it says that the mode is now disabled. However it doesn't do anything after I type C-c { to insert an environnment template...

There is a package, but the documentation says that I shouldn't use it since it's embedded in emacs.

  • I'm having your same problem! emacswiki.org says to download a script written by Carsten Dominik himself from this link, but where to put it in a Windows 7 machine? C:\home\.emacs.d\??? – WobblyWindows Jan 18 '16 at 14:15
  • This other page says to give the following command: M-x package-install [RET] cdlatex [RET]. I've tried, but emacs says [No match]. So back to problem #1 -- where to put the script cdlatex-4.0.el? – WobblyWindows Jan 18 '16 at 14:34
  • 1
    You can put it anywhere in the file system. The only restriction is that the directory must be in the list of load-path. Of course it must also be readable for emacs. Furthermore, I assume that you should rename cdlatex-4.0.el to cdlatex.el. But the latter is just a guess. – Tobias Jan 20 '16 at 17:41
  • But the wiki saiy not to install cdlatex because it is now built in. – Nicolas Scotto Di Perto Jan 20 '16 at 18:35
  • @Tobias is right. Type C-h v RET load-path RET to get list of all load-paths where to choose from. I chose to put cdlatex.el in C:\Program Files\emacs-24.4\share\emacs\24.4\lisp from the list of possible load paths, then restarted the machine. In Org-mode activate CDLaTeX with M-x org-cdlatex-mode and try inserting some math etc. I'm having some extra trouble with the backquote symbol, I'm getting error msg "Wrong type argument: characterp, 134217782", don't know why. If CDLaTeX is off, backquote is all right. Can anyone suggest a fix up? – WobblyWindows Jan 21 '16 at 0:37
1

I solved a similar (possibly the same problem) by installing auctex, like this:

M-x package-install RET auctex RET

I suppose that there is a dependency that both cdlatex and auctex need but which was not installed with cdlatex.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.