1

following the tutorial http://orgmode.org/worg/org-tutorials/org-R/org-R.html, I get stuck because I can't find the function org-R-apply.

I have R installed on my computer and the package ess has been installed with usepackage ((use-package ess :ensure t)) which automatically does the require, and added the entry (R . t) to babel suppported languages.

I also have tried to require ess-site manually as it has a different name from the package, but the function is still not here.

  • Unfortunately that article is outdated. First paragraph says Org-R has been replaced by Org-babel.... org-R-apply is not in Org anymore. If you want to see the now deprecated code, look in org-R.el. – undostres Jan 18 '16 at 1:36
  • So what is the replacing function ? I'll probably check the .el today. – Nicolas Scotto Di Perto Jan 18 '16 at 7:27
  • I'm not sure if there's a replacement. ob-R.el doesn't have a similar function. It would be best to peruse org-R.el and copy/adapt the org-R-apply function manually, if possible. – undostres Jan 18 '16 at 18:21
1

Looking at your tutorial , I have never used the #+R specification.

Recent (>2 years old) org-mode mainly uses code blocks to input several R lines. Add this to your dotemacs:

(org-babel-do-load-languages
 'org-babel-load-languages
 '((R . t)))

Then in an org file C-c C-v C-d and select R to create a R source block. C-c C-c inside the block to evaluate it, C-c <backquote> to edit it with ess.

More info here: http://orgmode.org/worg/org-contrib/babel/languages/ob-doc-R.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.