4

When using global-linum-mode with a latex file that has blocks of R code (*.rnw file) moving in and out of the R code blocks cause the line numbers to disappear until the cursor is moved again. Is there a way to stop the disappearing line numbers or just to turn off the line numbers for *.rnw files, but not in pure LaTeX ESS files?

Using Aquamacs 3.2 GNU Emacs 24.4.51.2 ESS-Version 15.09-2

  • 1
    Try setting the value of linum-eager to t in your init file to see if they update more reliably (this might slow things down though). – elethan Jan 22 '16 at 16:26
  • I can't reproduce that problem with ESS-Noweb and LaTeX mode. Are you using polymode? That would explain this, as when the cursor moves in and out of R chunks you are actually moving in and out of major modes while you do so. If this is the case, make sure linum-mode is enabled for .R source files, and they shouldn't disappear. – Tyler Jan 22 '16 at 17:01
  • Thank you elethan for you advice, seems to have done the trick. Tyler thank you for trying to replicate. – mjb Jan 24 '16 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.