2

Emacs "suddenly" stopped automatically inserting the correct quotes once I hit the " key. It seems to me that this is due to a duplicate installation of some package, but I can't put my finger on it.

There are some commands that seem to duplicates, so far I stumbled over the following:

latex-mode
LaTeX-mode
tex-insert-quote
TeX-insert-quote (")
tex-insert-braces
TeX-insert-braces (C-C {)

Sadly, even though helm tells me that TeX-insert-quote is bound to ", it does not seem to trigger. And even if I call it manually, it simply inserts " into my text instead of ``correct'' quotes.

Can anybody point me out where to start diagnosing this behaviour?

Edit: After running C-h k " emacs tells me that it's indeed bound to TeX-insert-quote. So the trouble is not the binding, but something else.

5
  • 3
    Ask Emacs what command is bound to " with C-h k ". Start your Emacs without your init file (emacs -Q). Then, recursively bisect your init file (comment out components) until you find out what's causing the conflict.
    – Dan
    Commented Jan 28, 2016 at 13:30
  • Thanks, that allowed me to verify my bindings are correct. Commented Jan 28, 2016 at 16:10
  • have you managed to fix this? I'm having the same issue Commented May 28, 2016 at 15:02
  • 1
    Sorry, I haven't made any progress on this issue. Currently I am inserting the correct quotes like a caveman :( Commented May 28, 2016 at 15:54
  • @MatíasGuzmánNaranjo I just found out that my expectation was simply wrong, maybe that is the case for you as well? Commented Aug 15, 2016 at 13:02

1 Answer 1

1

Turns out that the behaviour of TeX-insert-quote has changed from what I was used to. If I simply hit " twice the correct quotation characters are inserted. It used to insert "` or "' immediately, but now does so after the second stroke.

2
  • Do you load babel package with a particular language option? The behavior depends on it, nothing changed in the last years.
    – giordano
    Commented Aug 15, 2016 at 16:33
  • Wow, that might be the root cause: This indeed only happens with german documents. And the more I think about it ... Around the time I asked the question I got around writing german documents in LaTeX for more or less the first time. Commented Aug 19, 2016 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.