0

I have 2 university server I can connect to and I set up the config files in the ~/.ssh directory to connect to them just by using an alias.

Until 1 or 2 days ago both of them were working fine but now I cannot connect to one of them through TRAMP (I still can connect fine using the terminal).

The following is the tramp log, it seems the initial connection get established but then something happen that doesn't allow it to go further.

Linux access.chaos-cluster.uni.lux 3.2.0-4-amd64 unknown
18:05:38 up 199 days, 23:06,  3 users,  load average: 0.06, 0.05, 0.05
[01;32m0 [36;1m18:05:38[0m [0;37username[0m@[4;36maccess[0m([1mchaos-cluster[0m)[0;31m[0m[0;32m (master #)[0m [34;1m~[0m $ 
18:06:37.592257 tramp-process-sentinel (5) # Sentinel called: `#<process *tramp/ssh chaos-cluster*>' `killed
'
18:06:37.607714 tramp-process-actions (1) # File error: Timeout reached, see buffer `*tramp/ssh chaos-cluster*' for details
18:07:07.641803 tramp-maybe-open-connection (3) # Opening connection for chaos-cluster using ssh...failed
18:07:07.642873 tramp-get-remote-stat (5) # Finding a suitable `stat' command
18:07:07.643063 tramp-file-name-handler (1) # Suppress received in operation (file-attributes /ssh:chaos-cluster:/userpath)
18:07:07.643464 tramp-get-test-command (5) # Finding a suitable `test' command
18:07:07.643625 tramp-file-name-handler (1) # Suppress received in operation (file-readable-p /ssh:chaos-cluster:/userpath)

I have searched for solution on internet but I didn't find solutions for similar situations. Does anybody knows what it could be?

Thanks in advance!

P.S. I am using spacemacs on emacs 24.5.1 and debian testing.

  • You did run into a timeout. And your prompt looks very strange, very likely Tramp couldn't detect it: "[01;32m0 [36;1m18:05:38[0m [0;37username[0m@[4;36maccess[0m([1mchaos-cluster[0m)[0;31m[0m[0;32m (master #)[0m [34;1m~[0m $ ". Pls change your .profile such a way that a simple prompt is shown. The Tramp manual discusses this. – Michael Albinus Feb 1 '16 at 10:21
  • But the fact is that the same server was working before and the other university server that has the exact same prompt is working fine with tramp. Do you think it can be something else? I will try to change it meanwhile – Alberto Mengali Feb 1 '16 at 11:23
  • I don't think anything before seeing the traces :-) – Michael Albinus Feb 1 '16 at 12:57
  • I changed my prompt so that now it only is [user@access] ~(chaos-cluster) $> but i still get the same error. How can I get these traces you are refering to? – Alberto Mengali Feb 1 '16 at 14:56
  • It would be hard to pinpoint where tramp is failing without a debug trace. See the tramp manual on how to generate a debug trace. – Emacs User Feb 1 '16 at 15:36
0

As suggested in the answer from Michael Albinus, the problem was in tramp not recognizing my prompt string. In particular it was due to the presence of a git status in my prompt that was something like "(master #)", with the # causing tramp not to recognize the prompt.

I changed my .bashrc file to avoid fancy prompts when connecting through TRAMP and the issue is now solved.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.