0

Elpy works in every buffer automaticly, however I wan it to work only with python files. The related section of my init.el is:

(require 'elpy)
(elpy-use-ipython)
(setq-default indent-tabs-mode nil)

(add-to-list 'auto-mode-alist '("\\.py\\'" . elpy-mode))

I clarify my question: Elpy as a minor mode is activated in all of my buffers, and shadows important key-bindings such as C-c C-c for magit.

  • Please clarify what you mean by "work". E.g. tell us precisely what behavior you see in non-python buffers and which you dislike there. – Stefan Feb 5 '16 at 18:09
  • @Stefan I updated my question. – atevm Feb 5 '16 at 18:17
1

The problem was that I added elpy-mode as hook for flyspell-prog-mode before I enabled elpy, so it activated it globally. I wrote that part of my config one week after I started using Emacs half year ago, So it was easy to forget.

  • You can delete your post by the way. – ReneFroger Feb 5 '16 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.