2

I'm using my local emacs to edit files on a remote cluster. Therefore I added:

[[ $TERM == "dumb" ]] && unsetopt zle && PS1='$ ' && return

to my remote .zshrc and I can edit and browse files without any problems. I can even compile (M-x compile) file using:

gcc test.c -o test

I checked: It runs on the cluster and not my local machine, however if I run:

mpicc -std=c99 -Wall -o exec heat.c
/bin/sh: line 2: mpicc: command not found

If I do the same in a regular SSH-Session it works without any problems.

How can I use mpicc on the cluster from emacs?

emacs -Q doesn't help.

  • 2
    Does this have to do with your PATH? (i.e. do you make modifications to the path that you are skipping for dumb terminals?) – PythonNut Feb 10 '16 at 0:15
2

Your $PATH settings in your init file are not taken into account per default. Try the following:

(add-to-list 'tramp-remote-path 'tramp-own-remote-path)

See also the Tramp manual discussing this setting.

  • At first it didn't work, because 'tramp-remote-path was void, but (require 'tramp) fixed it. – Stein Feb 10 '16 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.