3

I've enabled some new packages in bbatsov's prelude and when I restart the emacs daemon, it hangs endlessly starting up showing this:

Prelude is powering up... Be patient, Master g!
Loading personal configuration files in /Users/g/.emacs.d/personal/preload...
Loading Prelude's core...
Loading /Users/g/.emacs.d/savefile/recentf...
Loading /Users/g/.emacs.d/savefile/recentf...done
Loading Prelude's modules...
Loading /Users/g/.emacs.d/prelude-modules.el (source)...
Contacting host: melpa.org:443
Opening TLS connection to `melpa.org'...
Opening TLS connection with `gnutls-cli --insecure -p 443 melpa.org'...

What's the problem exactly? I can access https://melpa.org/ without any problems.

Any workarounds?

Cheers,

4

I got around this by first starting emacs with emacs --insecure and once that worked and downloaded and what it needed, I was able to start emacs --daemon fine.

1

On Windows 10, I solved the problem by starting Emacs with the admin prompt (seems that admin rights matter). Also, you should check on whether gnutls is properly installed, following the instructions here: https://stackoverflow.com/questions/36950871/failed-to-download-melpa-archive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.