4

I'm using Emacs GUI on OSX and I've remapped Cmd key to meta by adding the following to a ~/.emacs.d/personal/misc.el file on prelude:

(setq mac-command-modifier 'meta)

Whereas C-M-u works as expected, C-M-d, when using Cmd as meta key, does nothing. If using alt key though, it works as expected.

What can I do to solve this? I've tried typing C-h l to see what's being typed but when I type C-M-d, nothing appears.

Any ideas?

Cheers

  • 1
    This sounds like it might be a system level OSX keyboard shortcut that is overriding an Emacs one. I had a similar issue on Ubuntu getting M-SPC to work in Emacs. If you know how to change/disable the OSX binding for Ctrl + Command + d, that might do the trick. – elethan Feb 23 '16 at 19:50
  • @elethan, you are a legend!! Your clue lead to me to the answer, which is explained here :D – Galder Zamarreño Feb 24 '16 at 7:51
  • nice! Happy to help! – elethan Feb 24 '16 at 12:44
2

Elethan's tip lead me to the answer here, which essentially involves disabling system wide OSX Command-Control-D shortcut by calling:

defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 70 '<dict><key>enabled</key><false/></dict>'
  • @elethan et al, I've sent a PR to mathiasbynens's .osx dotfiles so that it gets disabled there and many Emacs users can benefit. Vote it up! :) – Galder Zamarreño Feb 24 '16 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.