4

I'm using Tramp with the scpx method to run the compile command on a remote machine. The build takes several minutes to run. If I try to work on something else while that runs that ends up trying to use Tramp, Emacs hangs and then the compilation buffer appears to abort the build.

For example, one time I started the compilation and then went to a dired buffer of the remote machine and tried to navigate, and that caused this to happen.

Another time, after starting the compilation, I tried to use ido-find-file on a remote path, and the compilation buffer failed.

I'm very new to Tramp and Emacs. Should Tramp be able to handle multiple processes at the same time? I wonder if I don't have something misconfigured.

Thank you!

1

Tramp is able to run several compile processes in parallel. It is the compile command which prevents this due to the hard-coded buffer name.

Check the docstring of compile by C-h f compile. There you see

To run more than one compilation at once, start one then rename the ‘compilation’ buffer to some other name with M-x rename-buffer. Then switch buffers and start the new compilation. It will create a new ‘compilation’ buffer.

  • Thanks for the response, Michael. I guess I wasn't clear with my question. I'm not trying to run M-x compile again. I'm trying to do ido-find-file while the compilation buffer's process is still running. – Daniel Matz Mar 28 '16 at 20:31
  • I see. I've tried to reproduce your problem with a recent Emacs 25.1 / Tramp 2.3.0-pre, but everything works as expected. Which Emacs / Tramp versions are you using? – Michael Albinus Mar 29 '16 at 18:37
  • I'm using Emacs 24.5.1, with Tramp 2.2.11-24.5. – Daniel Matz Mar 29 '16 at 21:10
  • I've tried to reproduce it with GNU Emacs 24.5.1 / Tramp 2.2.11-24.5, as brought by Ubuntu 15.10. I've used your scenario, calling M-x compile on a remote host, and calling M-x ido-find-file while the compilation was still running. No problem. The only difference might be that I have started Emacs as emacs24 -Q. Have you tried it yourself, starting Emacs with the -Q option? – Michael Albinus Apr 9 '16 at 8:35
  • I hadn't tried that, but you are right, my problem goes away when I use emacs -Q. So does that mean that something in my init.el is causing an issue? – Daniel Matz Apr 11 '16 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.