1

I installed LLVM on my Windows machine. And now I want Emacs tools to use it. I changed company-clang-executable to "path/to/LLVM/bin/clang.exe". Now I think it finds Clang but somehow completions does not work. It only completes trivial things like main, double etc. I feel like I have to add some directories for company to look but I don't know how. I found ways of adding your own projet's directory but thats all.

EDIT: Here is what I did so far. I have;

(eval-after-load "company"
      (setq company-clang-arguments "-I/c/msys64/include"))

I also ofcourse did standard things from manual beforehand to enable company-clang. I also checked with Emacs M-! that Emacs recognize executable named clang. But still no completion.

  • Have you looked in the clang-errors buffer? It might complain about missing includes for example. I'm also struggling with company-clang on windows so I'm interested how this can be resolved. – B_old Oct 17 '17 at 14:32
  • I could not achieve it at the time and I still can't. Things work fine on Linux but not on Windows for reasons beyond me. – meguli Oct 18 '17 at 19:30
  • I'm at a point where (I think) clang finds all the headers and is now complaining about the actual code, which it apparently can't parse. Maybe some defines are missing... – B_old Oct 18 '17 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.