14

I am very new to LaTeX and exporting org-mode files to pdf. When I run the command org-latex-export-to-pdf it adds a title, author name, and date to the top of the exported pdf. Looking at the generated LaTeX, I assume that comes from the lines:

\author{Ethan Skinner}
\date{\today}
\title{My Title}

How can I export a pdf without these properties? I have tried using both the VISIBLE-ONLY and BODY-ONLY arguments to org-latex-export-to-pdf, but this didn't work for me

  • 3
    I think #+OPTIONS: author:nil will remove the author from exports, I'm almost sure the rest can be handled by options too, but I don't remember the syntax for it. – wvxvw Mar 18 '16 at 19:50
21

OK, thanks to @wvxvw putting me on the right track I figured it out.

You can get rid of the author and date with:

#+OPTIONS: author:nil date:nil

The Org Manual says that you can also toggle title with title:nil (org-export-with-title). However, this option didn't get rid of the title, and I couldn't find a variable or command org-export-with-title. However, from this thread I found that I can get rid of the title simply by adding: #+TITLE: and not entering a title. This does add an extra line to my document, and it seems like it would make more sense to do it in the #+OPTIONS, but this will do.

  • Is there a way to permanently change that? So that you don't have to add it to every single org file/section you want to export? Thanks for helping! – Guilherme Salomé Jul 19 '17 at 4:53
  • title:nil is working for me under org-mode 9.1. :-) – Dieter.Wilhelm May 22 '18 at 20:15
9

You can also redefine LaTeX's \maketitle to do nothing:

#+Title: Test title
#+Author: Test Author
#+Date: [2016-03-28 Mon]

#+LATEX_HEADER: \renewcommand\maketitle{}

* hello
test text

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.