0

I'm trying to create the new empty file

  1. Tried 'c'
  2. Tried C-x C-f

when I type "mixins.py" Find file always suggest me to open the file in other directory with the same name, so I'm forced to create the file in shell and then reload dired with 'g'

this becomes very annoying. How to fix it? I still like the ability for emacs to suggest me the path based on file name, but I also want to create empty files when needed.

  • 3
    Please give a step-by-step recipe to reproduce the problem, preferably starting from emacs -Q (no init file). I have no problem creating a new, empty file with the same name as an existing file but in a different directory. – Drew Mar 19 '16 at 1:41
2

It is possible that you have ido-mode enabled, which would cause this problem. You can find out by pressing C-h c C-x C-f to find out what command C-x C-f is bound to. If it is bound to ido-find-file, then try this:

  1. C-x C-f to run ido-find-file.
  2. Type the directory where you want to create the file.
  3. C-f to fallback to the non-ido version of find-file
  4. Type the filename (ie mixins.py) and press enter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.