0

I have Slime configured with fuzzy completion and it works perfectly when I'm using it in X11 mode (M-TAB, list of completions pops up in a separate buffer, C-n/p allows to choose the right completion, TAB makes use of chosen completion). However, when I run Emacs in TTY mode (-nw option), that last step fails, i.e. I get a list of completions, can navigate across them, but pressing TAB on my choice does not select it. I am, however, able to select it by pressing Enter, but this also results in a newline being inserted, which is annoying. Any idea why there is such a discrepancy between those two modes?

EDIT:

I'm using Emacs version 26.0.50.2 (but this also happened in previous versions - 24 and 25). My Slime version is 20161109.640 (installed from MELPA). Below is the part of the config relevant to Slime:

;;;;;;;;;;;;;;;;;
;; Common Lisp ;;
;;;;;;;;;;;;;;;;;

(setq auto-mode-alist
      (append auto-mode-alist
          '(("\\.cl\\'" . lisp-mode)
        ("\\.lsp\\'" . lisp-mode))))
(slime-setup '(slime-fancy
           slime-media
           slime-asdf
           slime-tramp))
(setq slime-enable-evaluate-in-emacs t)
(add-to-list 'slime-contribs 'slime-autodoc)
(add-to-list 'slime-contribs 'slime-trace-dialog)
(setq slime-complete-symbol*-fancy t)
(setq slime-complete-symbol-function 'slime-fuzzy-complete-symbol)
2
  • Just a guess: could it be that Slime binds the command you want to the [tab] key sequence, instead of binding it to "\t"?
    – Stefan
    Mar 24, 2016 at 13:48
  • Please post a small init file that reproduces the problem, and tell us what version of Emacs and Slime you're using. Otherwise it's a shot in the dark. Dec 20, 2016 at 12:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.