2

After updating my Emacs packages, org capture templates fail with Capture template `a': outline-show-all, where a is the capture keystroke.

Backtrace:

Debugger entered--Lisp error: (error "Capture template `a': outline-show-all")
  signal(error ("Capture template `a': outline-show-all"))
  error("Capture template `%s': %s" "a" outline-show-all)
  byte-code("\301p!\203�\302\303\304 \"\203�\305p!\210\306\307\310!!\210\300\311\307\312!A@#\207" [error buffer-base-buffer string-match "\\`CAPTURE-" buffer-name kill-buffer set-window-configuration org-capture-get :return-to-wconf "Capture template `%s': %s" :key] 4)
  org-capture(nil)
  #<subr call-interactively>(org-capture nil nil)
  ad-Advice-call-interactively(#<subr call-interactively> org-capture nil nil)
  apply(ad-Advice-call-interactively #<subr call-interactively> (org-capture nil nil))
  call-interactively(org-capture nil nil)
  command-execute(org-capture)

I am also getting org-agenda-change-all-lines: Symbol's function definition is void: org-get-at-eol.

I have tried recompiling all packages with M-: (byte-recompile-directory package-user-dir nil 'force), but no improvement.

I am using Emacs 24.5.1 and Org version 8.2.10.

  • Worked around the issue by uninstalling and reinstalling Emacs. It seems that I mistakenly replaced the built-in org package with MEPLA's. – Matthew Piziak Mar 29 '16 at 0:51
  • For me, just restarting Emacs fixed the issue. – THIS USER NEEDS HELP Apr 13 '16 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.