2

Whenever I double-click files on finder to open them using emacs, they open in existing buffers. Instead I would like them to open in separate frames by default.

It seems as though many others have also queried this issue on StackExchange but I still haven't been able to find a satisfactory answer.

I've been trying to use display-buffer-alist and display-buffer-pop-up-frame but the documentation for this is very confusing and I couldn't find the right phrasing for my init.el file.

I'm using OS X El Capitan 10.11.3, and Emacs 24.5.1 with this version: https://github.com/railwaycat/emacs-mac-port

  • 1
    1) Tell the Emacs developers that you find this particular doc confusing, and why, so they can improve it - M-x report-emacs-bug. 2) Try setting option pop-up-frames to t, as a start. – Drew Apr 4 '16 at 3:57
  • Thanks for the reply. Do you mean adding: (setq pop-up-frames t) to the init.el file? This doesn't work. – hyunjik11 Apr 4 '16 at 10:45
  • Yes. When you use "-other-window" commands, it should cause buffers (not just file buffers, though) to be shown in a separate frame instead of a separate window. It's only a start. – Drew Apr 4 '16 at 15:18
  • From superuser.com/a/431601/4910 (setq ns-pop-up-frames nil) – Harvey Jul 21 '16 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.