1

I open a terminal and type fg like it says but it says no current process.

I also tried %emacs and got the same.

I'm on trusty tahr 14.04, anyone else got this? *edit: I was following the built-in tutorial.

  • 4
    That may not be enough information to answer the question. How did you start emacs? Is it running as a terminal application or as a gui application with a proper os window (you didn't say what OS you're using, but it wouldn't matter; in this case C-z will iconify or minimize the window as appropriate for the OS). – db48x Apr 4 '16 at 1:58
  • 1
    Works for me. Are you sure everything is working correctly? Does this work in bash and emacs -Q? – PythonNut Apr 4 '16 at 5:04
  • Try pkill -CONT emacs but as others have said there is not enough information to answer. – Icarus Apr 4 '16 at 11:22
  • 1
    Are you running fg in the same terminal you started emacs in? – T. Verron Apr 4 '16 at 12:29
  • 1
    Did you start Emacs in the background, to begin with? If not then it's no wonder that fg won't move it to the foreground. Try starting Emacs using emacs & instead of just emacs, if you haven't tried that already. As others have indicated, your question is quite poor - no specific description, no recipe to reproduce the problem. Don't make people guess what you did and what you're asking. Otherwise, you likely won't get good help, and the question might be closed as unclear. – Drew Apr 4 '16 at 15:20
3

The fg job control command should work if you run from the same terminal where you entered Control-z.

To find out what processes are available to be placed in the fore ground use the jobs command. If jobs does not list your Emacs process, you're in the wrong shell.

| improve this answer | |