4

I noticed that Emacs has many font files open on my system. At least 95 .ttf and .otf files total. Why would it need to keep this many files open?

Here is a full list: https://gist.github.com/landaire/2a4346b97792f2987c4ac39bcd7295f6

Here's some info about my setup:

  • OS: darwin
  • Emacs: 25.1.50.1 (from a recent brew install emacs --HEAD --with-cocoa)
  • Spacemacs: 0.105.16
  • Spacemacs branch: master (rev. cf8563b)
  • Graphic display: t
  • Distribution: spacemacs
  • Editing style: vim
  • Completion: helm
  • Layers:

    (auto-completion better-defaults emacs-lisp git org
                     (shell :variables shell-default-height 30 shell-default-position 'bottom)
                     syntax-checking version-control semantic c-c   d go rust swift yaml latex markdown gtags osx spacemacs-layouts themes-megapack
                     (colors :variables colors-enable-rainbow-identifiers nil))
    
3
  • 2
    Same on mine. Doesn't appear to be spacemacs-specific. I note, however, that they are all memory-mapped and not open file descriptors, according to lsof. I suspect this comes with the territory for any GUI app on OS X. And it is unlikely to be a resource problem, as all applications will share these. – Harald Hanche-Olsen Apr 5 '16 at 19:26
  • 2
    @HaraldHanche-Olsen that's good to know. However, some other GUI applications such as iTerm2 and Safari don't have nearly as many files open so it's definitely something odd that Emacs is doing. If it's not using any resources though then yeah, not a big deal. – Lander Apr 5 '16 at 19:53
  • It could depend on which underlying libraries are being used. I have lost track of the various GUI components of OS X and their relationship – quartz, cocoa and so forth. – Harald Hanche-Olsen Apr 5 '16 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.